re = /^if\s*\((.+)\)\s((?:(?!else|endif).)+)(?:\selse\s((?:(?!endif).)+))?\sendif$/m
str = 'if(stat(life) >= 2) abc(5) deal_damage(5) else gain_block(5) endif
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end