#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)[a-z]+([\n].*?<\/div>[\n ]+<div class="large-3 small-3 columns">[\n ]+)[a-z]+"
Local $sString = "" & @CRLF & _
"<div class="row">" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"> ← 1500 ⨯ <img src="/static/currency/Orb_of_Alteration.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 columns">" & @CRLF & _
" <div class="displayoffer-primary displayoffer-centered">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" exalted" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 small-6 columns displayoffer-text">" & @CRLF & _
" <div class="displayoffer-left"><img src="/static/currency/Exalted_Orb.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-right"><img src="/static/currency/Orb_of_Alteration.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-middle">1 ⇐ 1500</div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" alteration" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Orb_of_Alteration.png" class="currencyimg"> → 0.0007 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="row">" & @CRLF & _
" <div class="large-12 columns">" & @CRLF & _
" <div class="displayoffer-bottom">IGN: MoreSpellDamage <span class="right"><a href="#" onclick="contact_form(this); return false;">Contact seller</a></span></div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" <div class="displayoffer" data-username="joshxx" data-sellcurrency="6" data-sellvalue="1.0" data-buycurrency="7" data-buyvalue="1650.0" data-ign="joshhhz">" & @CRLF & _
"<div class="row">" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"> ← 1650 ⨯ <img src="/static/currency/Chromatic_Orb.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 columns">" & @CRLF & _
" <div class="displayoffer-primary displayoffer-centered">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" exalted" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 small-6 columns displayoffer-text">" & @CRLF & _
" <div class="displayoffer-left"><img src="/static/currency/Exalted_Orb.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-right"><img src="/static/currency/Chromatic_Orb.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-middle">1 ⇐ 1650</div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" chrome" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Chromatic_Orb.png" class="currencyimg"> → 0.0006 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="row">" & @CRLF & _
" <div class="large-12 columns">" & @CRLF & _
" <div class="displayoffer-bottom"><span class="success label">online</span> · IGN: joshhhz <span class="right"><a href="#" onclick="contact_form(this); return false;">Contact seller</a></span></div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" <div class="displayoffer" data-username="deadlylegolas" data-sellcurrency="6" data-sellvalue="1.0" data-buycurrency="7" data-buyvalue="1700.0" data-ign="LegoSaiyanGod">" & @CRLF & _
"<div class="row">" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"> ← 1700 ⨯ <img src="/static/currency/Chromatic_Orb.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 columns">" & @CRLF & _
" <div class="displayoffer-primary displayoffer-centered">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" exalted" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-6 small-6 columns displayoffer-text">" & @CRLF & _
" <div class="displayoffer-left"><img src="/static/currency/Exalted_Orb.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-right"><img src="/static/currency/Chromatic_Orb.png" class="currencyimg"></div>" & @CRLF & _
" <div class="displayoffer-middle">1 ⇐ 1700</div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 small-3 columns">" & @CRLF & _
" chrome" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large-3 columns displayoffer-centered">" & @CRLF & _
" <small>1 ⨯ <img src="/static/currency/Chromatic_Orb.png" class="currencyimg"> → 0.0006 ⨯ <img src="/static/currency/Exalted_Orb.png" class="currencyimg"></small>" & @CRLF & _
" </div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")