$re = '/^(?!07).*$/m';
$str = '01 testing
07 testing
02 testing
07 testing
something else entirely';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);