re = /^(?!07).*$/m
str = '01 testing
07 testing
02 testing
07 testing
something else entirely'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end