package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(?:-\d{3}){3}\d$`)
var str = `2-123-123-1234
123-123-123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}