$re = '/^\d(?:-\d{3}){3}\d$/m';
$str = '2-123-123-1234
123-123-123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);