$re = '/(https?:\/\/)?(v|player)\.youku\.com\/(v_show|player\.php|embed)(\/sid)?\/(id_)?(\w+)|(\w+)/i';
$str = 'http://v.youku.com/v_show/id_XMTMwMDYxMjQxMg==_ev_1.html?from=y1.3-idx-uhome-1519-20887.205805-205902.1-1
http://v.youku.com/v_show/id_XMjMxOTQyOTQw.html?from=y1.6-97.3.1.a44aa406e0c711df97c0
http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html?from=y1.3-idx-uhome-1519-20887.205921-205922-205810-205923.1-1
http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html
http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf
http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf
http://player.youku.com/embed/XMTI5Mjg5NjE4MA==';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);