re = /value="(.*?)"/m
str = '<input type="hidden" name="OFBIZ_FRAMEWORK_REQUEST_SYNCH_TOKEN" value="1590137573579">\\n";
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end