$re = '/value="(\d*)"/m';
$str = '<input type="hidden" name="OFBIZ_FRAMEWORK_REQUEST_SYNCH_TOKEN" value="1590137573579">\\n";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);