$re = '/<img.*?src=[\'"]\K[^\'"?]+/';
$str = '<img src="http://example.com/wp-content/uploads/2013/11/dsc_0546.jpg?w=640">
<img src="http://example.com/wp-content/uploads/2013/12/dsc_0547.jpg?w=1080">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);