import Foundation
let pattern = #"<img.*?src=['"]\K[^'"?]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="http://example.com/wp-content/uploads/2013/11/dsc_0546.jpg?w=640">
<img src="http://example.com/wp-content/uploads/2013/12/dsc_0547.jpg?w=1080">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)