import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?) es.*de (.*)$";
final String string = "\n"
+ " Abejorral es una población y municipio del departamento de Antioquia\n"
+ " Ábrego es una población y municipio del departamento de Norte de Santander\n"
+ " Abriaquí es una población y municipio del departamento de Antioquia\n"
+ " Acacías es una población y municipio del departamento de Meta\n"
+ " Acandí es una población y municipio del departamento de Chocó\n"
+ " Acevedo es una población y municipio del departamento de Huila\n"
+ " Achí es una población y municipio del departamento de Bolívar\n"
+ " Agrado es una población y municipio del departamento de Huila\n"
+ " Agua de Dios es una población y municipio del departamento de Cundinamarca\n"
+ " Aguachica es una población y municipio del departamento de Cesar\n"
+ " Aguada es una población y municipio del departamento de Santander\n"
+ " Aguadas es una población y municipio del departamento de Caldas\n"
+ " Aguazul es una población y municipio del departamento de Casanare\n"
+ " Agustín Codazzi es una población y municipio del departamento de Cesar\n"
+ " Aipe es una población y municipio del departamento de Huila\n"
+ " Albán es una población y municipio del departamento de Cundinamarca\n"
+ " Albania es una población y municipio del departamento de Caquetá\n"
+ " Albania es una población y municipio del departamento de La Guajira\n"
+ " Albania es una población y municipio del departamento de Santander\n"
+ " Alcalá es una población y municipio del departamento de Valle del Cauca\n"
+ " Aldana es una población y municipio del departamento de Nariño\n"
+ " Alejandría es una población y municipio del departamento de Antioquia\n"
+ " Algarrobo es una población y municipio del departamento de Magdalena\n"
+ " Algeciras es una población y municipio del departamento de Huila\n"
+ " Almaguer es una población y municipio del departamento de Cauca\n"
+ " Almeida es una población y municipio del departamento de Boyacá\n"
+ " Alpujarra es una población y municipio del departamento de Tolima\n"
+ " Altamira es una población y municipio del departamento de Huila\n"
+ " Alto Baudó es un municipio (cuya capital es Pie de Pato) del departamento de Chocó\n"
+ " Altos del Rosario es una población y municipio del departamento de Bolívar\n"
+ " Alvarado es una población y municipio del departamento de Tolima\n"
+ " Amagá es una población y municipio del departamento de Antioquia\n"
+ " Amalfi es una población y municipio del departamento de Antioquia\n"
+ " Ambalema es una población y municipio del departamento de Tolima\n"
+ " Anapoima es una población y municipio del departamento de Cundinamarca\n"
+ " Ancuyá es una población y municipio del departamento de Nariño\n"
+ " Andalucía es una población y municipio del departamento de Valle del Cauca\n"
+ " Andes es una población y municipio del departamento de Antioquia\n"
+ " Angelópolis es una población y municipio del departamento de Antioquia\n"
+ " Angostura es una población y municipio del departamento de Antioquia\n"
+ " Anolaima es una población y municipio del departamento de Cundinamarca\n"
+ " Anorí es una población y municipio del departamento de Antioquia\n"
+ " Anserma es una población y municipio del departamento de Caldas\n"
+ " Ansermanuevo es una población y municipio del departamento de Valle del Cauca\n"
+ " Anzá es una población y municipio del departamento de Antioquia\n"
+ " Anzoátegui es una población y municipio del departamento de Tolima\n"
+ " Apartadó es una población y municipio del departamento de Antioquia\n"
+ " Apía es una población y municipio del departamento de Risaralda\n"
+ " Apulo es una población y municipio del departamento de Cundinamarca\n"
+ " Aquitania es una población y municipio del departamento de Boyacá\n"
+ " Aracataca es una población y municipio del departamento de Magdalena\n"
+ " Aranzazu es una población y municipio del departamento de Caldas\n"
+ " Aratoca es una población y municipio del departamento de Santander\n"
+ " Arauca es un municipio y capital del departamento de Arauca\n"
+ " Arauquita es una población y municipio del departamento de Arauca\n"
+ " Arbeláez es una población y municipio del departamento de Cundinamarca\n"
+ " Arboleda es un municipio (cuya capital es Berruecos) del departamento de Nariño\n"
+ " Arboledas es una población y municipio del departamento de Norte de Santander\n"
+ " Arboletes es una población y municipio del departamento de Antioquia\n"
+ " Arcabuco es una población y municipio del departamento de Boyacá\n"
+ " Arenal es una población y municipio del departamento de Bolívar\n"
+ " Argelia es una población y municipio del departamento de Antioquia\n"
+ " Argelia es una población y municipio del departamento de Cauca\n"
+ " Argelia es una población y municipio del departamento de Valle del Cauca\n"
+ " Ariguaní es un municipio (cuya capital es El Difícil) del departamento de Magdalena\n"
+ " Arjona es una población y municipio del departamento de Bolívar\n"
+ " Armenia es una población y municipio del departamento de Antioquia\n"
+ " Armenia es una población y municipio del departamento de Quindío\n"
+ " Armero es un municipio (cuya capital es Guayabal) del departamento de Tolima\n"
+ " Arroyohondo es una población y municipio del departamento de Bolívar\n"
+ " Astrea es una población y municipio del departamento de Cesar\n"
+ " Ataco es una población y municipio del departamento de Tolima\n"
+ " Ayapel es una población y municipio del departamento de Córdoba\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}