// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?) es.*de (.*)$").unwrap();
let string = "
Abejorral es una población y municipio del departamento de Antioquia
Ábrego es una población y municipio del departamento de Norte de Santander
Abriaquí es una población y municipio del departamento de Antioquia
Acacías es una población y municipio del departamento de Meta
Acandí es una población y municipio del departamento de Chocó
Acevedo es una población y municipio del departamento de Huila
Achí es una población y municipio del departamento de Bolívar
Agrado es una población y municipio del departamento de Huila
Agua de Dios es una población y municipio del departamento de Cundinamarca
Aguachica es una población y municipio del departamento de Cesar
Aguada es una población y municipio del departamento de Santander
Aguadas es una población y municipio del departamento de Caldas
Aguazul es una población y municipio del departamento de Casanare
Agustín Codazzi es una población y municipio del departamento de Cesar
Aipe es una población y municipio del departamento de Huila
Albán es una población y municipio del departamento de Cundinamarca
Albania es una población y municipio del departamento de Caquetá
Albania es una población y municipio del departamento de La Guajira
Albania es una población y municipio del departamento de Santander
Alcalá es una población y municipio del departamento de Valle del Cauca
Aldana es una población y municipio del departamento de Nariño
Alejandría es una población y municipio del departamento de Antioquia
Algarrobo es una población y municipio del departamento de Magdalena
Algeciras es una población y municipio del departamento de Huila
Almaguer es una población y municipio del departamento de Cauca
Almeida es una población y municipio del departamento de Boyacá
Alpujarra es una población y municipio del departamento de Tolima
Altamira es una población y municipio del departamento de Huila
Alto Baudó es un municipio (cuya capital es Pie de Pato) del departamento de Chocó
Altos del Rosario es una población y municipio del departamento de Bolívar
Alvarado es una población y municipio del departamento de Tolima
Amagá es una población y municipio del departamento de Antioquia
Amalfi es una población y municipio del departamento de Antioquia
Ambalema es una población y municipio del departamento de Tolima
Anapoima es una población y municipio del departamento de Cundinamarca
Ancuyá es una población y municipio del departamento de Nariño
Andalucía es una población y municipio del departamento de Valle del Cauca
Andes es una población y municipio del departamento de Antioquia
Angelópolis es una población y municipio del departamento de Antioquia
Angostura es una población y municipio del departamento de Antioquia
Anolaima es una población y municipio del departamento de Cundinamarca
Anorí es una población y municipio del departamento de Antioquia
Anserma es una población y municipio del departamento de Caldas
Ansermanuevo es una población y municipio del departamento de Valle del Cauca
Anzá es una población y municipio del departamento de Antioquia
Anzoátegui es una población y municipio del departamento de Tolima
Apartadó es una población y municipio del departamento de Antioquia
Apía es una población y municipio del departamento de Risaralda
Apulo es una población y municipio del departamento de Cundinamarca
Aquitania es una población y municipio del departamento de Boyacá
Aracataca es una población y municipio del departamento de Magdalena
Aranzazu es una población y municipio del departamento de Caldas
Aratoca es una población y municipio del departamento de Santander
Arauca es un municipio y capital del departamento de Arauca
Arauquita es una población y municipio del departamento de Arauca
Arbeláez es una población y municipio del departamento de Cundinamarca
Arboleda es un municipio (cuya capital es Berruecos) del departamento de Nariño
Arboledas es una población y municipio del departamento de Norte de Santander
Arboletes es una población y municipio del departamento de Antioquia
Arcabuco es una población y municipio del departamento de Boyacá
Arenal es una población y municipio del departamento de Bolívar
Argelia es una población y municipio del departamento de Antioquia
Argelia es una población y municipio del departamento de Cauca
Argelia es una población y municipio del departamento de Valle del Cauca
Ariguaní es un municipio (cuya capital es El Difícil) del departamento de Magdalena
Arjona es una población y municipio del departamento de Bolívar
Armenia es una población y municipio del departamento de Antioquia
Armenia es una población y municipio del departamento de Quindío
Armero es un municipio (cuya capital es Guayabal) del departamento de Tolima
Arroyohondo es una población y municipio del departamento de Bolívar
Astrea es una población y municipio del departamento de Cesar
Ataco es una población y municipio del departamento de Tolima
Ayapel es una población y municipio del departamento de Córdoba
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}