package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:100|[1-9]?[0-9])$`)
var str = `0
1
10
11
99
100
101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}