$re = '/^(?:100|[1-9]?[0-9])$/m';
$str = '0
1
10
11
99
100
101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);