$re = '/\([^\)]*\)*/';
$str = 'hello(there)
how(are(you(today))) my(lad)
I\'m (fine) (thanks)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);