import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=params\\.).*?(?=\\])";
final String string = "function pastEvents(username, params) { // 305\n"
+ " /** //\n"
+ " * @description Docs: http://www.songkick.com/developer/past-events-for-user //\n"
+ " * @param {string} username //\n"
+ " * @param {object} [params={}] //\n"
+ " * @param {number} [params.page=1] //\n"
+ " * @param {number} [params.per_page=50] - 50 is the max //\n"
+ " * @param {string} [params.order='asc'] - 'asc' or 'desc' //\n"
+ " * @returns {Promise} //\n"
+ " */ //\n"
+ " params = params ? params : {}; // 315\n"
+ " var url = _this.user.baseURL + username + '/gigography.' + _this.format + '?apikey='; // 316\n"
+ " return _performRequest(url, params); // 318\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}