const regex = /(?<=params\.).*?(?=\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=params\\.).*?(?=\\])', 'gm')
const str = `function pastEvents(username, params) { // 305
/** //
* @description Docs: http://www.songkick.com/developer/past-events-for-user //
* @param {string} username //
* @param {object} [params={}] //
* @param {number} [params.page=1] //
* @param {number} [params.per_page=50] - 50 is the max //
* @param {string} [params.order='asc'] - 'asc' or 'desc' //
* @returns {Promise} //
*/ //
params = params ? params : {}; // 315
var url = _this.user.baseURL + username + '/gigography.' + _this.format + '?apikey='; // 316
return _performRequest(url, params); // 318
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}