const regex = /^\s*?([\d\.]+(\,\d{1,2})?|\,\d{1,2})\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*?([\\d\\.]+(\\,\\d{1,2})?|\\,\\d{1,2})\\s*$', '')
const str = `000,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}