$re = '/^\s*?([\d\.]+(\,\d{1,2})?|\,\d{1,2})\s*$/';
$str = '000,00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);