import re
regex = re.compile(r"data-reactid=\"([0-9a-zA-Z\.\$\:]*)\"")
test_str = "<div class=\"Select is-searchable\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0\"><input type=\"hidden\" value=\"\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.0\"><div class=\"Select-control\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1\"><div class=\"Select-placeholder\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1.0:$placeholder\">Select...</div><div class=\"Select-input\" style=\"display:inline-block;\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1.1\"><input value=\"\" tabindex=\"0\" style=\"width:5px;\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1.1.0\"><div style=\"position: absolute; visibility: hidden; height: 0px; width: 0px; overflow: scroll; white-space: nowrap; font-size: 16.2000007629395px; font-family: montserrat, sans-serif;\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1.1.1\"></div></div><span class=\"Select-arrow\" data-reactid=\".0.2.0.0.$1.0.0.0.1.0.0.1.2\"></span></div></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")