#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!^)\D+"
Local $sString = "+12foo4 4 456--"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)