$re = '/(?!^)\D+/';
$str = '+12foo4 4 456--';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;