package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?P<id>[1-9][\d]*)$`)
var str = `1
-1
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}