$re = '/^(?P<id>[1-9][\d]*)$/uDmi';
$str = '1
-1
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);