using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"video.*\K%7bmatch%7";
string input = @"video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}