re = /video.*\K%7bmatch%7/
str = 'video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length'
# Print the match result
str.match(re) do |match|
puts match.to_s
end