$re = '/(—)(?!.*\—).*/';
$str = 'Hello — guys. What is your — name23123@asldkma)@(.i2jPID289129d';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);