re = /(—)(?!.*\—).*/
str = 'Hello — guys. What is your — name23123@asldkma)@(.i2jPID289129d'
# Print the match result
str.match(re) do |match|
puts match.to_s
end