#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(,\s*)\b(https?:\/\/[^,]+)(\s*,)"
Local $sString = "Something,https://stackoverflow.com/questions/ask/,Anotherthing" & @CRLF & _
"Something,https://stackoverflow.com/questions/ask,Anotherthing" & @CRLF & _
"link:https://www.google.com/something,something else" & @CRLF & _
"http://www.domain.com/without-ssl" & @CRLF & _
"Something followed by a space, https://domain.com, more to come" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")