// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(,\s*)\b(https?:\/\/[^,]+)(\s*,)").unwrap();
let string = "Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}