use strict;
my $str = 'Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 € ';
my $regex = qr/(?<=^Total revenue for )(\d+[-_]?\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}