re = /(?<=^Total revenue for )(\d+[-_]?\d+)/m
str = 'Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 € '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end