// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""score":(-)?[0-9]+"#).unwrap();
let string = "{\"score\":0,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":-1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}
{\"score\":1,\"compare\":0,\"words\":[\"book\",\"planet\",\"sun\",\"science\"],\"words\":[],\"good\":[],\"bad\":[]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}