# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*?\/(?:Accept|Integrate))$"
test_str = ("c:/project1/main/Node/Accept/testCase1/Browse.c\n"
"c:/project1/main/Node/Accept/testCase2/navigate.c\n"
"c:/project1/main/Node/Accept/testCase2/save.c\n"
"c:/project1/main/Node/Accept/testCase4/search.c\n"
"c:/project1/main/Node/Accept\n"
"c:/project1/main/Node/Integrate\n"
"c:/project1/main/Node/Accept/destroy/fullCoverage/remove.py\n"
"c:/project1/main/Tree/Integrate/testCase1/Browse.c\n"
"c:/project1/main/Tree/Integrate")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.