package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]+\.[A-Z]+`)
var str = `EG.VISIT ADEG.DTYPE ADEG.DTYPE ADEG.ADY ADEG.AWTARGET ADEG.AWTDIFF ADEG.DTYPE ADEG.DTYPE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}