re = /[A-Z]+\.[A-Z]+/
str = 'EG.VISIT ADEG.DTYPE ADEG.DTYPE ADEG.ADY ADEG.AWTARGET ADEG.AWTDIFF ADEG.DTYPE ADEG.DTYPE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end