$re = '/(?<!\S)(?!FILE:)\S+/m';
$str = 'FILE:abc LENGTH:123 AUTHOR:Bobby
FILE:xyz LENGTH:987 AUTHOR:Sabine
FILE:xyz LENGTH:987 AUTHOR:Sabine:test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);