const regex = /.+?>\s*?(.+?)<\/.+?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?>\\s*?(.+?)<\\\/.+?>', 'g')
const str = `<div><span>text text</span></div><a href="#">link</a>
<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w="12">good</pos></p>
text<a href="#">text link</a>
<button>name</button><textarea></textarea>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}