re = /.+?>\s*?(.+?)<\/.+?>/
str = '<div><span>text text</span></div><a href="#">link</a>
<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>
<p><pos w="12">good</pos></p>
text<a href="#">text link</a>
<button>name</button><textarea></textarea>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end