package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\pL\d](?:\h[\pL\d])*$`)
var str = `A
A 3 B
V 3 A 3 B
G B A 3 B 9 V
A3
A3 B H 6
A3B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}