$re = '/^[\pL\d](?:\h[\pL\d])*$/m';
$str = 'A
A 3 B
V 3 A 3 B
G B A 3 B 9 V
A3
A3 B H 6
A3B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);