# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[a-zA-Z0-9]\w+(?:\.\w+)+$/$1/gm;t' <<< "word1.word2
word1.word2.word3
word1.word2.word3.word4
word.word.
word..word
qweqrqerq"