$re = '/((?:http(?:s)?:\/\/)?\S+\.\S+\.\S+) | ((?:[0-9]{1,3}\.){3}[0-9]{1,3})/';
$str = '
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);