re = /((?:http(?:s)?:\/\/)?\S+\.\S+\.\S+) | ((?:[0-9]{1,3}\.){3}[0-9]{1,3})/
str = '
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end