$re = '~^http(?:s)?://(?:www.)?facebook.com/(?:video.php\?v=|video/video.php\?v=|photo.php\?v=|v/|.*?/videos/)([\d]+?)(&\S+?)?$~m';
$str = 'https://www.facebook.com/video.php?v=100000000000000
https://www.facebook.com/username1/videos/100000000000000
https://www.facebook.com/username2/videos/100000000000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);