// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http(?:s)?://(?:www.)?facebook.com/(?:video.php\?v=|video/video.php\?v=|photo.php\?v=|v/|.*?/videos/)([\d]+?)(&\S+?)?$").unwrap();
let string = "https://www.facebook.com/video.php?v=100000000000000
https://www.facebook.com/username1/videos/100000000000000
https://www.facebook.com/username2/videos/100000000000000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}