using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])([A-Z])|(?<=[A-Z])([A-Z])(?=[a-z])";
string input = @"ThisStringHasNoSpacesASCIIButItDoesHaveCapitalsLINQ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}