re = /(?<=[a-z])([A-Z])|(?<=[A-Z])([A-Z])(?=[a-z])/
str = 'ThisStringHasNoSpacesASCIIButItDoesHaveCapitalsLINQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end