using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"qt[^cy].*?[^<>\d](\d{3})(?:\D|$)";
string input = @"EKG done this AM with QT 560 and QTC wnl at 535ms, higher than on exam performed 5/3/2015 which showed...";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}